Degraded Performance in Billing (Invoice) Processes
Incident Report for Ducky Cloud
Resolved
This incident has been resolved.
Posted Jan 28, 2025 - 23:27 CST
Monitoring
We have completed the test and now migrating the existing logic.
Posted Jan 27, 2025 - 11:39 CST
Update
We have completed the majority of the work and are currently testing its usability. After the testing is finished, we will migrate the existing logic. More updates will follow shortly.
Posted Jan 26, 2025 - 17:52 CST
Update
We are continuing to work on a fix for this issue.
Posted Jan 23, 2025 - 20:29 CST
Update
We have completed the design for Billing V2. Currently, we have tested features including direct invoice payments, paying invoices with account balance, combined invoice payments, and invoice completion operations. We are continuing to design and test additional features such as invoice due date reminders and invoice cancellation. More updates will follow shortly.
Posted Jan 17, 2025 - 20:13 CST
Update
We have successfully completed the data restructuring and partial logic refactoring, and are currently conducting thorough testing to ensure optimal performance. Our next steps include feasibility validation, stress testing, and migrating existing logic to the upgraded framework. We are also developing a combined payment feature, enabling users to utilize both their account balance and external payment methods simultaneously. We appreciate your patience and support throughout this process—more updates will follow shortly.
Posted Jan 11, 2025 - 12:02 CST
Update
We are continuing to work on a fix for this issue.
Posted Jan 05, 2025 - 13:20 CST
Update
We are continuing to work on a fix for this issue.
Posted Jan 03, 2025 - 18:18 CST
Update
We have observed that the billing system may experience random interruptions. We are continuing to investigate and resolve the issue.
Posted Jan 01, 2025 - 17:32 CST
Update
We have successfully resolved the recent issue affecting the renewal process, ensuring that your service’s expiration dates are now accurately updated upon payment. Our team is continuing to monitor and address any related matters to maintain seamless and uninterrupted service for all users.
Posted Dec 31, 2024 - 16:09 CST
Identified
We have identified a decline in the performance of our current billing system, with primary issues including reduced processing speeds and diminished functionality. Specifically, when users activate auto-renewal but have insufficient account balances, the insufficient balance reminders are ineffective, resulting in the generation of unpaid invoices. Additionally, even after users replenish their balances, payments are not processed and remain unresolved, preventing successful transactions. Furthermore, users are currently unable to directly manage and execute invoice payments, restricting their ability to address billing issues promptly. To address these challenges, we are undertaking a comprehensive refactoring of the billing logic. This redevelopment aims to enhance processing efficiency and restore full functionality to the billing system. We estimate that this improvement process will require approximately two to three weeks to complete.
Posted Dec 28, 2024 - 21:08 CST
This incident affected: Billing (Invoice).